Building FreeNAS

How to set up a build environment for customizing FreeNAS

Adjusted from instructions in the FreeNAS wiki.

Install FreeBSD 7.2

  1. Boot up the FreeBSD 7.2 installer disc
  2. Country Selection
  3. Console keymap
  4. Installation Mode - Express (Begin a quick installation (for expert)'ts)
  5. Destination - press "A" to use the entire disk and then "Q" to quit
  6. Boot Manager - use the FreeBSD boot manager.
  7. Disk Label creation - press "A" for an auto configuration. and then "Q" to accept and quit
  8. Package selection - select "Developer". Answer "no" to installing the ports collection.
  9. Installation media - select the FreeBSD CD/DVD
  10. General configuration - set a root password, turn on networking and enable SSHD.
  11. Boot into the new install

Finalize the installation

  1. Install some necessary tools:

    pkg_add -r bash
    pkg_add -r cdrtools
    pkg_add -r subversion
  2. Install FreeBSD security updates:
    freebsd-update fetch install
  3. Update the port database:
    portsnap fetch extract

    Replace sh with bash:

    cd
    cp .profile .bashprofile

    Add the following to the end of .bashprofile:

    # set prompt: ``username@hostname:/directory $ ''
    PS1="[\u@\h:\w] "
    case `id -u` in 0)
    PS1="${PS1}# ";; *)
    PS1="${PS1}$ ";;
    esac
  4. Install PHP:
    pkg_add -r php5

Compling FreeNAS
Download the FreeNAS source:

mkdir /usr/local/freenas
cd /usr/local/freenas
svn co https://freenas.svn.sourceforge.net/svnroot/freenas/trunk svn

Compile it:

cd /usr/local/freenas/svn/build
./make.sh

Recent Updates

  • 1 year 12 months ago
  • 1 year 12 months ago
  • 1 year 12 months ago
    php 8.x
  • 1 year 12 months ago
    10.6.7
  • 2 years 1 day ago
    Drop Centos 5/6 stuff